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Microsoft Excel: Advanced 

Import Data 
Data for analysis is frequently imported into spreadsheets, commonly from downloaded files. 
These files are often in CSV (Comma Separated Values) format, a straightforward text format easily 
opened with basic text editors like Notepad or more sophisticated programs such as Excel. 

A C T I V I T Y  1 :  I M P O R T  D ATA  
1. Start Excel and click NEW → BLANK WORKBOOK. 
2. Click FILE → SAVE AS → BROWSE. 
3. Navigate to the desired file location and save it with the name 30-Pivot . 
4. Click DATA → GET & TRANSFORM → FROM TEXT/CSV. 
5. Navigate to 30-Data.csv. 
6. Click IMPORT. 
7. Excel will start a wizard to import the CSV data. Since Excel correctly determined the type 

of data being imported, click LOAD. 
8. Close the Queries & Connections panel by clicking the X in the top right corner of that 

panel. 
9. Right-click the Sheet2 tab and choose RENAME from the pop-up menu. 
10. Enter Sales Data  as the new name for this tab. 
11. Right-click the Sheet1 tab and choose DELETE from the pop-up menu. 
12. Save the workbook. 

Introduction To Pivot Tables 
Pivot tables are a popular analytical tool for dynamically summarizing data, valued for their 
customizability and power. They allow easy shifting of data between rows and columns, hence the 
name 'pivot'. Also known as contingency tables or crosstabs, pivot tables are commonly used in 
reports to present tabular data. 

Create Pivot Tables for Data Analysis 
Follow these steps to create a new pivot table from the Sales Data worksheet. 

 A C T I V I T Y  2 :  C R E AT E  A  P I V O T  T A B L E  
1. Click A1. 
2. Click INSERT → TABLES → PIVOTTABLE. 
3. Ensure New Worksheet is selected as the location of the new pivot table. 
4. Click OK. 
5. A pivot table is created on a new worksheet. Rename that sheet Sales Pivot . 
6. Move the Sales Pivot worksheet to the right of Sales Data. 

 

A C T I V I T Y  3 :  S E T  U P  A  P I V O T  T A B L E  
1. Drag and drop Location in the Field List to the Rows area. 
2. Drag and drop Product Line in the Field List to the Rows area under Location. 
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3. Drag and drop Weekly Sales in the Field List to the Values area. 
4. Click and drag Product Line from the Rows area to the Columns area. 

 

A C T I V I T Y  4 :  U S E  T O TA L S  I N  A  P I V O T  T A B L E  
1. Click the ↓ (down arrow) in Sum of Weekly Sales in the Values area. 
2. Select VALUE FIELD SETTINGS. 
3. Change Custom Name to Average Sales . 
4. Select AVERAGE. 
5. Click OK. 
6. The average is displayed with seven decimal places, but only two are needed. 
7. Click the ↓ (down arrow) in Average Sales in the Values area. 
8. Select VALUE FIELD SETTINGS. 
9. Click the NUMBER FORMAT button. 
10. Choose NUMBER and set 2  decimal places (the default setting). 
11. Click OK two times. 
12. Right-click on G5 (the first Grand Total cell). 
13. Select SORT → SORT LARGEST TO SMALLEST. 

 

A C T I V I T Y  5 :  U S E  C A L E N D A R  D ATA  
1. Click A1 in the Sales Data worksheet. 
2. Click INSERT → TABLES → PIVOTTABLE. 
3. Click NEW WORKSHEET. 
4. Click OK. 
5. Rename the new worksheet Annual Pivot  and move it to the right of Sales Pivot. 
6. Click DATE in the Field List. 
7. Drag Weekly Sales from the Field List to Values. 
8. Click the plus sign beside the month names in the table to drill down to weeks and days. 
9. Drag Location from the Field List to Columns. 
10. Save the worksheet. 

 

A C T I V I T Y  6 :  S O R T  A N D  F I LT E R  A  P I V O T  T A B L E  
1. To filter the data, click the ↓ (down arrow) to the right of the Row Labels headers on the 

pivot table. Click to include only JAN, FEB, and MAR. 
2. Click the ↓ (down arrow) to the right of the Row Labels header on the pivot table. Click 

SELECT ALL. 
3. Click the ↓ (down arrow) to the right of the Column Labels header on the pivot table. Click 

SORT Z TO A. Observe that the locations are now sorted in reverse alphabetical order. 
4. Click the ↓ (down arrow) to the right of the Column Labels header on the pivot table. Click 

SORT A TO Z to return the table to its default sort order. 
5. Save the workbook. 
6. Click A5. 
7. To delete Days from the date, click PIVOTTABLE ANALYZE → GROUP  → GROUP FIELD. 
8. Click DAYS to unselect it. Months should be the only Grouping variable left. 
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9. Click OK. 
10. Drag Product Line from the Field List to the Filters area. 
11. Click the ↓ (down arrow) in B1. 
12. Select BOOKS. 
13. Click OK. Notice that the pivot table is instantly updated to include only sales of books. 
14. Click the ↓ (down arrow) in B1. 
15. Select ALL. 
16. Click OK. 
17. Save the workbook. 

 

A C T I V I T Y  7 :  U S E  A  R E C O M M E N D E D  P I V O T  T A B L E  
1. Click A1 in the Sales Data worksheet. 
2. Click INSERT → TABLES → RECOMMENDED PIVOTTABLES. 
3. Excel will analyze the data and create several recommended pivot tables. Click the first 

recommended pivot table, SUM OF WEEKLY SALES BY LOCATION. 
4. Click OK. 
5. Excel creates the pivot table in a new worksheet. Name that worksheet Sales By 

Location . Move Sales By Location to the right of Annual Pivot. 
6. Save the workbook. 

Create A Pivot Chart 
One of the strengths of creating a pivot table is that the table can be used to create a chart and as 
the table is modified, the chart is also automatically adjusted. Follow these directions to explore 
the power of pivot charts. 

A C T I V I T Y  8 :  C R E AT E  A  P I V O T  C H A R T  
1. Click A1 in the Sales Data worksheet. 
2. Click INSERT → CHARTS → PIVOT CHART. 
3. In the Create PivotChart popup, ensure NEW WORKSHEET is selected. 
4. Click OK. 
5. Rename the pivot chart worksheet to Sales By Product Line . 
6. Move Sales By Product Line to the right of Sales By Location. 
7. In the Field List, check LOCATION and WEEKLY SALES. 
8. In the Field List, uncheck LOCATION and select PRODUCT LINE. 
9. On the chart, click the ↓ (down arrow) beside Product Line and check only BOOKS. 
10. On the chart, click the ↓ (down arrow) beside Product Line and check SELECT ALL. 
11. Click DESIGN → TYPE → CHANGE CHART TYPE. 
12. Select PIE CHART. 
13. Click OK. 
14. Click the + sign at the top right of the pie chart and then click DATA LABELS. 
15. In the Values area, click SUM OF WEEKLY SALES → VALUE FIELD SETTINGS → NUMBER FORMAT. 
16. Click NUMBER. 
17. Specify 0  decimal places and check USE 1000 SEPARATOR (,). 
18. Click OK two times. 
19. Click off the chart so it is no longer selected, and then right-click on the chart title. 
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20. Select EDIT TEXT from the popup menu. 
21. Enter Sales By Product Line  as the chart title. 
22. Other chart elements can be changed using the Design tab. 
23. Save and close the workbook. 

Advanced Data Analysis 

Solver For What-If Analysis 
The Excel Solver is an advanced tool used for forecasting and optimizing solutions for intricate 
business challenges. In this case, the PeopleMover Transportation Company aims to use Solver in a 
spreadsheet to identify the optimal mix of motor coaches for a contract. 

Solver is an add-in that is integrated into Excel, but it requires activation before use. This is a one-
time process; if Solver is already active, this step can be omitted from the exercise. 

 A C T I V I T Y  9 :  A C T I VAT E  T H E  S O LV E R  A D D - I N  
1. Click FILE. 
2. Click OPTIONS at the bottom of the left-hand menu. 
3. Click ADD-INS. 
4. Select EXCEL ADD-INS. 
5. Click GO. 
6. Click the checkbox beside SOLVER ADD-IN. 
7. Click OK. 

 

A C T I V I T Y  1 0 :  L O A D  T H E  S O LV E R  D ATA  F I L E  
1. Click FILE → OPEN → BROWSE. 
2. Navigate to 31-Data and click OPEN. 
3. Click FILE → SAVE AS → BROWSE. 
4. Navigate to the desired file location and save it with the name 31-Solver . 

 

A C T I V I T Y  1 1 :  U S E  P E O P L E - M O V E R  
1. Click DATA → ANALYZE→ SOLVER. 
2. In the Set Objective box, click the selector button and then click B12 to select it. Note: 

since cell B12 has a name, the Solver may display the name Ttl_Cost instead of B12. 
3. For To, Select MIN so the Solver looks for the minimum cost. 
4. For By Changing Variable Cells, enter E6:E9  to change the number of coaches. 
5. Click ADD beside the Subject to the Constraints box. 
6. Specify E6<=D6  so the coaches allotted do not exceed those on hand and click ADD. 
7. Specify that E6  must be an INT since partial coaches are impossible. 
8. Click OK. Note that the Solver will display the cell names: Del_Altd means Deluxe Allotted 

and Del_OH means Deluxe on Hand. 
9. Add similar constraints for Large (cell E7), Mid-Size (cell E8), and Mini (cell E9) coaches 

like those for the Deluxe coach. 
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10. Add a constraint that B11>=B15  since all riders need to have a seat on a coach. 
11. When completed, the Constraints box should have the requirements illustrated on the 

right. 
12. Check the box for MAKE UNCONSTRAINED VARIABLES NON-

NEGATIVE since a negative number of coaches or riders is 
impossible. 

13. For Select a Solving Method, use the default: GRG 
NONLINEAR. 

14. Click SOLVE. 
15. Click OK on the Solver Results dialog box. 
16. Save and close the workbook. 

Scenario Manager for Multiple Scenarios 
Excel users often adjust variables in a worksheet to observe different outcomes. For instance, a 
business owner might analyze "best case" and "worst-case" scenarios and then compare the 
results. This method of exploring various possibilities in Excel is known as creating scenarios.  

 A C T I V I T Y  1 2 :  U S E  T H E  S C E N A R I O  M A N A G E R  
1. Click FILE → OPEN → BROWSE. 
2. Navigate to 32-Data and click OPEN. 
3. Click FILE → SAVE AS → BROWSE. 
4. Navigate to the desired file location and save it with the name 32-Senario . 
5. Click DATA ⇒ FORECAST ⇒ WHAT-IF ANALYSIS ⇒ SCENARIO MANAGER. 
6. Click ADD in the Scenario Manager box. 
7. Enter these values in the Add Scenario box. 

a. Scenario Name: Current . The first scenario will be the current budget and will 
work as a baseline for the other scenarios. 

b. Changing Cells: B6:B7, B17:B26. These are the cells that the user can change for 
each scenario. 

c. Comment: Baseline budget , a brief description of the scenario’s purpose. 
d. Prevent Changes: CHECKED to protect the changing cell values. 
e. Hide: UNCHECKED so the changing cells are visible. 

8. Click OK. 
9. The Scenario Values box will pop up. This is where changeable values are entered. 
10. Click OK since none of the values will be changed. 
11. The Scenario Manager will pop up. There is one scenario named Current. 
12. Click ADD to create a new scenario. 
13. Enter Vacation  for the scenario name and Vacation budget  as a comment. 
14. Click OK. 
15. Change these values: Clothing, 0 ; Gifts, 0 ; Transportation, 800 . 
16. Click OK. 
17. Select VACATION and click SHOW in the Scenario Manager box. 
18. Select CURRENT and click SHOW in the Scenario Manager box. 
19. Click ADD in the Scenario Manager. 
20. Name the new scenario Home improvement  and enter Bathroom remodel  as 

a comment. 

Del_Altd <= Del_OH 

Del_Altd = integer 

Lar_Altd <= Lar_OH 

Lar_Altd = integer 

Mid_Altd <= Mid_OH 

Mid_Altd = integer 

Min_Altd <= Min_OH 

Min_Altd = integer 

Ttl_Cap >= Trip_Riders 
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21. Click OK. 
22. Change these values: Clothing, 0 ; Dining Out, 0 ; Gifts, 0 ; Groceries, 500 ; Subscriptions, 

100 . 
23. Click OK. 
24. Select CURRENT and click SHOW in the Scenario Manager box. 
25. Click ADD in the Scenario Manager. 
26. Enter Classes  for the scenario name and Career training  as a comment. 
27. Click OK. 
28. Change these values: Dining Out, 0 ; Gifts, 0 ; Shopping, 0 ; Transportation, 1000 ; 

Utilities, 600 . 
29. Click OK. 
30. Each of the four scenarios can be viewed by clicking its name and SHOW. 
31. Click SUMMARY in the Scenario Manager box. 
32. Select the SCENARIO SUMMARY radio button. 
33. For result cells, B29 is the best reporting option. 
34. Click OK. 
35. Save and close the workbook. 

Forecasting 
Following is an example of a forecast worksheet that uses beer production data to show a clear 
seasonal trend over time. 

A C T I V I T Y  1 3 :  F O R E C A S T I N G  
1. Click FILE → OPEN → BROWSE. 
2. Navigate to 33-Data and click OPEN. 
3. Save the workbook as 33-Beer . 
4. Click A1. 
5. Click DATA → FORECAST → FORECAST SHEET. 
6. Accept the default options and click CREATE. 
7. Rename Sheet1 to Forecast . 
8. Move the Forecast sheet to the right of the Beer Production sheet. 
9. Save the workbook. 

The graph shows the cyclic nature of beer production and forecasts a similar cycle out to December 
1994. 

Work With Data 

Protect Worksheets and Workbooks 
When managing a spreadsheet, it's often important to lock specific cells to prevent accidental 
modifications. This step ensures data integrity and maintains the spreadsheet's intended 
functionality. 

 A C T I V I T Y  1 4 :  P R O T E C T  W O R K S H E E T S  
1. Select A5:A9. These are the only cells that users should be able to modify. 
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2. Click HOME → CELLS → FORMAT → LOCK CELL. When locked, the cell lock icon will not be 
enclosed in a square. 

3. Click cell A1. 
4. Click HOME → CELLS → FORMAT → PROTECT SHEET. 
5. On the Protect Sheet dialog box, check Protect worksheet and contents of locked cells. 
6. Uncheck all options except Select Unlocked Cells. 
7. Click OK. 
8. Notice that now the mouse cannot click in any cell except A5:A9. 
9. Click HOME → CELLS → FORMAT → UNPROTECT SHEET. 
10. Select A5:A9. 
11. Click HOME → CELLS → FORMAT → LOCK CELL. When unlocked, the cell lock icon will be 

enclosed in a square. 
12. Save and close the workbook. 

 
Another option for securing a spreadsheet is to password-protect the entire workbook, which 
prevents it from being opened without the correct password. To do this, open the workbook and go 
to Review → Protect → Protect Workbook. However, be cautious: once a password is set, it cannot 
be bypassed, so it's crucial to not forget it. 

Export Data 
Exporting data from Excel in different formats can be vital. Consider this scenario: You're analyzing 
a spreadsheet, but not everyone uses Excel. Maybe colleagues use other software, or you need to 
upload data to a specific program. Exporting to formats like CSV, PDF, or XML ensures accessibility 
on various platforms. Formats like PDF also allow data sharing while preventing alterations. 
Mastering export options broadens your capabilities. 

Here are brief descriptions for several popular file types. 

• XLS: Excel's older proprietary format, less advanced than XLSX. 
• XLSX: Microsoft's current Excel format, feature-rich and widely used. 
• ODS: Open Document Spreadsheet, compatible with programs like LibreOffice. 
• CSV: Simple, text-based format for tabular data, easy to import/export. 
• XML: eXtensible Markup Language, versatile for structured data, often used in web data 

transmission. 
• PDF: Portable Document Format, read-only, preserves layout for printing. 

To export a workbook in a different format, click File → Save As and then choose the desired format 
from the drop-down menu. 

Fun Facts 
Excel is much more than just rows and columns. Here are a few interesting tidbits about Excel. 

1. Excel was first released by Microsoft in 1985. It has more than 1.2 billion users worldwide 
and is one of the most used software products in the business world. It has been helping 
professionals crunch numbers and manage data for over three decades now!  



Microsoft Excel: Advanced  Spring, 2024 

Cochise College Center for Lifelong Learning  P a g e  | 8 

2. The Easter Egg Game: Older versions of Excel included hidden Easter eggs. One of the most 
famous was a flight simulator in Excel 97. Just a little "egg-stra" fun! 

3. Cell Overload: Excel worksheets can hold 1,048,576 rows and 16,384 columns, or over 17 
billion cells. That's more cells than there are people on Earth! 

4. The 15-Digit Limit: Excel can only handle 15 significant digits in a single cell. Anything more, 
and it rounds off or replaces with zeros. So, maybe don't use Excel to calculate intergalactic 
distances! 

5. Scientists working on the HUGO Gene Nomenclature Committee had to rename some 
genes since Excel automatically formatted the original names as dates. For example, a gene 
was initially named MARCH1 (for Membrane Associated Ring-CH-Type Finger 1), but 
whenever MARCH1 is entered in Excel, it is formatted as a date. As a result, the name of this 
gene was changed to MARCHF1, and 27 other genes were also similarly renamed.  

6. Excel Music: Someone used Excel to compose music! You can hear the music and the 
composer’s explanation at this blog. Talk about a harmonious relationship between math 
and music! https://tinyurl.com/ny3mrknf. 

7. Excel Art: Tatsuo Horiuchi, a 73-year-old Japanese artist, creates impressive still-life art 
using only Excel as his canvas. Examples of his work and a brief explanation of how he 
makes them can be found at https://tinyurl.com/4zr5n92b. 

8. First Mouse Requirement: The first version of Excel was designed for the Macintosh and was 
one of the first software that required a mouse. 

Extra Practice 
To practice these skills, complete this employee analysis. 

A C T I V I T Y  1 5 :  O P E N  T H E  D ATA  F I L E  
1. Start Excel and click NEW → BLANK WORKBOOK. 
2. Click FILE → SAVE AS → BROWSE. 
3. Navigate to the desired file location and save it with the name 34-Employee . 
4. Click DATA → GET & TRANSFORM → FROM CSV. 
5. Navigate to 34-Data.csv. 
6. Click IMPORT. 
7. Click LOAD. 
8. Close the Queries & Connections panel. 
9. Delete Sheet1. 
10. Rename the 34-Data tab to EMPLOYEE DATA. 
11. Save the Workbook. 

 
Question 1: What is the average salary for each role? 

 A C T I V I T Y  1 6 :  F I N D  T H E  A V E R A G E  S A L A R Y  
1. Create a pivot table on a new worksheet and name that worksheet Avr Salary . Move 

the worksheet to the right of Employee Data. 
2. List the roles in the business (like Accounting and Associate), the number of people and 

average salary for each role. Hint: the Role field should be dragged to both the Rows and 
Values areas. 
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3. The Salary field should be changed from sum to average, and it should also be formatted 
as currency with two decimal places. 

4. Right-click C4 and sort the list to make the highest salary first. 
5. Save the workbook. 

  
Question 2: What is the average age of the employees when broken down by sex and marital 
status? 

 A C T I V I T Y  1 7 :  F I N D  T H E  A V E R A G E  A G E  
1. Click A1 in the Employee Data worksheet and create a pivot table on a new worksheet. 
2. Name the worksheet Avr Age  and move it to the right of Avr Salary. 
3. The pivot table should list the average age by marital status (rows) and sex (columns). 
4. The average age should be renamed Average Age  and formatted as a number with 

zero decimal places. 
5. Click D4. 
6. Using the formula bar, change the value to Avr Age . 
7. Save the workbook. 

 
Question 3: How many employees have been hired each year since 2007? 

 A C T I V I T Y  1 8 :  F I N D  E M P L OY E E  L O N G E V I T Y  
1. Click A1 in the Employee Data worksheet and create a pivot table on a new worksheet. 
2. The worksheet should be named Year Hired  and moved to the right of Avr Age. 
3. The pivot table should list the employee count by year hired. (Hint: count the username 

field since each employee has a unique username.) 
4. The username field should be labeled Count . 
5. The hired field should display only years, not quarters or months. 
6. The list should be sorted by year, with 2007 first (this is the default). 
7. Save the workbook. 

 
Question 4: How many employees work in each role? 

 A C T I V I T Y  1 9 :  C H A R T  R O L E  C O U N T S  
1. Click A1 in the Employee Data worksheet and create a pivot chart on a new worksheet. 
2. The worksheet should be named Count By Role Chart  and moved to the right of 

Year Hired. 
3. The pivot table should show the count by role. (Hint: count the username field since each 

employee has a unique username.) 
4. The Count of username field should be labeled Count by Role . 
5. Change the chart title to Count by Role . 
6. The data should be sorted such that the role with the most employees (Associate) should 

be first. 
7. Save and close the workbook. 
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Summary 
You've now explored many powerful Excel features for analyzing data and solving complex 
problems. From pivot tables to Solver, these tools offer immense capabilities. Don't let them gather 
virtual dust - put your new skills to work! Continue honing your Excel mastery. Implement what 
you've learned in real-world situations, whether personal, academic, or business projects. The 
more you practice, the more Excel excellence you'll achieve. Keep this handout for reference as you 
progress on your journey to Excel expertise! 
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Appendix: Additional Resources and References 
1. Online Learning Platforms 

• LinkedIn Learning (formerly Lynda.com) (https://www.linkedin.com/learning/) 
• Coursera (https://www.coursera.org/) 
• Udemy (https://www.udemy.com/) 
• EdX (https://www.edx.org/) 

These platforms provide a diverse range of Excel courses, catering to both beginners and 
advanced users, enabling students to enhance their Excel skills beyond traditional classroom 
learning. While these courses are not free, the platforms frequently offer sales and discounts, 
making them more affordable for learners. 

2. Excel Forums and Communities 

• Microsoft Excel Community (https://techcommunity.microsoft.com/t5/excel/bd-
p/ExcelGeneral) 

• Mr. Excel Forum (https://www.mrexcel.com/board/) 
• Excel Forum (https://www.excelforum.com/) 
• Reddit Excel (https://www.reddit.com/r/excel/) 

These forums and communities serve as valuable platforms for users to engage in discussions, 
seek assistance, and exchange knowledge with Excel enthusiasts and experts from around the 
world. Whether you have a specific question, want to share your expertise, or simply learn from 
others, these communities offer a supportive environment for all Excel users. 

3. Excel Blogs and Websites 

• Excel Jet (https://exceljet.net/) 
• Chandoo.org (chandoo.org) 
• Excel Easy (https://www.excel-easy.com/) 
• Contextures (https://www.contextures.com/) 

These educational blogs and websites provide tutorials, recommendations, and techniques to 
assist users in improving their Excel proficiency and remaining current with the latest 
capabilities and best practices. 


